富士通四国システムズ

  1. ホーム >
  2. 製品 & サービス >
  3. パッケージソフトウェア >
  4. 瞬快/kura >
  5. 技術情報 >
  6. 【ご連絡】(Rel.7.0)瞬快サーバインストールコンピュータをドメインコントローラに昇格すると瞬快サーバが起動できなくなる現象について

【ご連絡】(Rel.1.0)瞬快/kuraサーバインストールコンピュータをドメインコントローラに昇格すると瞬快/kuraサーバが起動できなくなる現象について

Rel.1.0において、瞬快/kuraサーバをインストール後、そのコンピュータをドメインコントローラに昇格したりメンバサーバに降格したりすると、瞬快/kuraサーバが起動できなくなる現象について、詳細を案内しています。

影響範囲

以下の製品をご利用のお客様に影響があります。

  • 瞬快/kura Rel.1.0(全製品)の瞬快/kuraサーバ

現象

以下の全ての条件を満たした場合に、瞬快/kuraサーバが起動できなくなる、または瞬快/kuraサーバが利用するSQL Serverがアンインストールできなくなります。

瞬快/kuraサーバをインストールする。

かつ、

瞬快/kuraサーバをインストールしたコンピュータをドメインコントローラに昇格させる。あるいは、もともとドメインコントローラであった瞬快/kuraサーバインストール済みコンピュータをメンバサーバに降格させる。

原因

Microsoft社よりSQL Serverをインストールした後にドメインコントローラのロールを変更する(メンバサーバからドメインコントローラに昇格する、あるいはドメインコントローラからメンバサーバに降格する)とSQL Serverが正しく機能しなくなることが広報されております。
ご参考:Microsoft社のサイト「3.10 Windows ドメイン コントローラへの SQL Server Express のインストール」(ページ中段あたり)
以上のことから、瞬快/kuraサーバインストール後にドメインコントローラのロールを変更すると、瞬快/kuraサーバが利用するSQL Serverが正しく動作しなくなるため本現象が発生します。

回避方法

ドメインの昇格/降格を行う場合は、予め瞬快/kuraサーバおよび瞬快/kuraサーバで利用するSQL Serverをアンインストールしてから実施してください。

現象発生時のリカバリ方法

本現象が発生した場合は、OSの再インストールが必要となります。OSを再インストールしてください。

補足

システムリカバリサーバに対しても類似の問題が確認されています。詳細はシステムリカバリサーバインストールコンピュータをドメインコントローラに昇格するとシステムリカバリサーバへ接続できなくなる現象についてを参照してください。